Your products may not be available in "My Stuff"
Incident Report for BILT Platform
Monitoring
A fix has been implemented, and we are monitoring the results. Please make sure to update the BILT app on your iOS device to the latest version, 5.38.1.
Posted Jan 10, 2024 - 13:34 CST
Investigating
Your previously downloaded products may not be available on "My Stuff" after re-logging in or logging in to BILT on another device. This also affects your ability to access your product registrations and receipts saved to the account. We are currently investigating the issue and aim to fix it as soon as possible.
Posted Jan 03, 2024 - 18:26 CST
This incident affects: Mobile apps (BILT app for iOS, BILT app for Android).